Meanwell LCM-40 (10V PWM) dimmen mit Arduino 5V PWM

sabrikara

Member
Hi zusammen,

hab heute weiter dran gearbeitet. Soweit alles fertig. Es muss nur noch das Netzteil ankommen.
Die ganzen Kabel sehen etwas abenteuerlich aus, aber wenn alles fertig ist, die Kabelfixiert und die Abdeckung drauf ist, sieht man nix mehr von.
Und da mich beim Bestellen der ganzen Sachen die Kauflust gepackt hat, teste ich mal so eine Pflanzenlampe, mal sehn.
 

Anhänge

  • IMAG1555.jpg
    IMAG1555.jpg
    1,4 MB · Aufrufe: 665
  • IMAG1557.jpg
    IMAG1557.jpg
    1,3 MB · Aufrufe: 664
  • IMAG1556.jpg
    IMAG1556.jpg
    1,4 MB · Aufrufe: 664

Wuestenrose

Well-Known Member
'N Abend...

sabrikara":1wrhcswb schrieb:
Und da mich beim Bestellen der ganzen Sachen die Kauflust gepackt hat, teste ich mal so eine Pflanzenlampe, mal sehn.
Das Led Tech Grow-Modul? Darüber breiten wir mal lieber den Mantel des Schweigens. Es beruht nicht auf den Erfahrungen vieler, sondern auf der Lautstärke eines Einzelnen...

Grüße
Robert
 

sabrikara

Member
Hi Robert,

genau das Teil. Irgendwo, bestimmt auch öfters, hatte ich schon gelesen, dass du des Meinung bist, diese farbigen Dinger keinen Vorteil bringen. Hatte ich beim Bestellen im Hinterkopf. Einfach mal testen und rum spielen.

Liebe Grüße
Sabri
 

sabrikara

Member
Morgen zusammen,

ich hab jetzt wirklich alles fertig gelötet. Nächstes mal würde ich statt die Mini Bucks, die normalen Buck KSQ nehmen. Das Löten ist Katastrophal. Vor allem für mich als Laie.
Die Lötstellen liegen viel zu dicht beieinander und sind einfach zu klein. Wenn man dann auch gleich zwei Kabel an eine Lötstelle anbringen will, wird es richtig schlimm.
Eine KSQ hab ich auch gleich zerstört, da kam die Lötstelle von der Platine ab und ich hab es dann nicht mehr hinbekommen, das Kabel dadran zu löten. Hab ich dann ausgetauscht. Zum Glück hatte ich noch einen Ersatz da.
(Den mir fehlenden hätte ich also eventuell doch noch gebraucht, Uwe – wenns nicht geklappt hätte.)

Die Platzierung der Mini KSQ, wenn man die Coverline benutzt, sollte genau mittig sein, sonst wirds schwierig. Ich hab keine Ahnung ob ich die mini Buck eventuell geschrottet hab. Das sehe ich dann, wenn ich die Lampe anschließe.
Wie auch immer – lieber die normalen Buck KSQ nehmen. Bei dieser hatte ich keine Probleme.

Außerdem sollte man sich über das "Kabel-Management" doch mehr Gedanken machen und die Kabel so legen, dass die später nicht weiter stören.

Jetzt kann ich die Lieferung des Netzteils auch kaum noch abwarten. Ich bin gespannt ob es funktioniert.
 
Hi Sabri,

ich sehe auch in den Minibucks überhaupt keine Vorteile, es sei denn, man ist wirklich auf den kleinen Bauraum angewiesen. Wärmetechnisch werden sie immer schlechter sein, als ein „normales“ Layout. Meine sind jetzt eingetroffen. Mal sehen, ob ich vom Sonntag ein Laborstündchen abknapsen kann.
Sieht aus, als ob Du massive Drähte nimmst. Da kommt beim Biegen ziemlich Kraft auf die Lötstellen. Litzen lassen sich auch besser zusammendrehen.

Grüße
Uwe
 
Guten Abend miteinander,

ich habe mir den 350mA-MiniBuck mal vorgeknöpft und siehe da, der im Datenblatt gezeigte Kurvenverlauf hat sich leider bestätigt. Mal schaun, vielleicht finde ich in den nächsten Tagen, woran es liegt.

Grüße
Uwe
 

Anhänge

  • MiniKSQ350mA_Vin-ILED.png
    MiniKSQ350mA_Vin-ILED.png
    28,8 KB · Aufrufe: 563

sabrikara

Member
Hi Uwe,

Danke für deine Mühe.
Erzähl doch mal etwas zu den gezeigten Kurven.
Je nach Anzahl Leds / angelegtem Volt etc. verschiedene Ausgangs-Strom?
 

sabrikara

Member
Hi zusammen,

ich hab nun endlich das Netzteil. Die kaltweißen LEDs leuchten, die warmweißen nicht.
Vermutet hatte ich es ja bereits, dennoch gehofft es wäre nicht. Womöglich habe ich also tatsächlich die Mini-Buck KSQ geschrottet beim Löten. (Sicher kann ich das natürlich nicht sagen. Ich gehe aber davon aus.)
Das heißt neu bestellen. Aber nicht die Minis.
 

sabrikara

Member
Hi zusammen,

hab jetzt die Mini Buck KSQ ausgetauscht. Beim Löten habe ich mich wie Magic Max gefühlt. :)
Kein Vergleich zu dem Mini Teil.
Wie erwartet, leuchten jetzt auch die "gelben" LED. Mir gefällts richtig gut. Nicht nur, dass es allgemein etwas heller ist, sondern grade auch das Gelbe. Rote Pflanzen sehen noch mal deutlich schöner aus.

Die nächsten Schritte sind also diese komische Uhr an den Arduino anschließen, PWM-Signal-Kabel anschließen und die Software überarbeiten. Ich glaube, wird cool :)
 

Anhänge

  • IMG_4260.JPG
    IMG_4260.JPG
    1,5 MB · Aufrufe: 495
  • IMG_4261.JPG
    IMG_4261.JPG
    1,5 MB · Aufrufe: 496
  • IMAG1571.jpg
    IMAG1571.jpg
    722,5 KB · Aufrufe: 497

sabrikara

Member
Hi zusammen,

PWM ist auch angeschlossen. Anders als man erwarten würde (oder ich erwartet hätte), muss der Ground vom Arduino nicht an das PWM - (minus) Pad von der KSQ. Dieser bleibt einfach frei.
Also PWM-Pin Arduino an PWM+ von der KSQ, Ground Ardunio an Minus Pad, wo auch das "Minus-Kabel" des Netzteils dran geht.
Das läuft jetzt alles immer noch ohne die RTC aber mit zwei Zeitschaltuhren, weil der Ardunio vor dem Licht angehen muss, um zeit zu haben, sein Programm zu starte, damit die Balken aus sind. Sonst gehen alle Lichter erst mal an, bis das Programm gestartet und die Lichter erst mal aus sind um dann aufgedimmt zu werden.
Der nächste Schritt ist also die RTC an den Arduino anzuschließen und das Programm umzuschreiben. Aber das eilt nicht.
Gedimmt wird insgesamt eine Stunde. Erst die "gelben" über 20 Minuten, dann die weißen, die mit auf dem selben Balken sitzen auch 20 Minuten und dann die zwei anderen Balken über 20 Minuten.
Ich hatte die Tabelle mit den PWM-Wert so an die ersten Balken angepasst, dass PWM-Wert die nicht ganz funktionierten, sprich die Lampe geblitzt hatte einfach aus der Tabelle genommen. Eventuell muss ich also für die anderen beiden Vorgänge eigene Tabellen einfügen, falls es zum Blinken kommt. Ich bin mir noch nicht sicher aber bei den neuen weißen ist es glaube ich der Fall. Schauen wir mal.
Hier ein Video. Schlecht gefilmt, miese Qualität aber nur damit ihr auch mal sehen könnt, was ich gemacht hab.

Danke für eure Hilfe bisher.

[BBvideo 425,350:256wd2fs]https://youtu.be/mAyfW12HhXs[/BBvideo]
 

omega

Well-Known Member
Hallo Sabri,

sabrikara":1k91llos schrieb:
Anders als man erwarten würde (oder ich erwartet hätte), muss der Ground vom Arduino nicht an das PWM - (minus) Pad von der KSQ. Dieser bleibt einfach frei.
nach meinem Verständnis ist PWM- eh mit GND der KSQ verbunden, also auch mit dem GND des Arduinos. Das zusätzliche Pad erspart einem das etwas mühseelige Anlöten zweier Litzen an ein Pad. Bei anderen KSQs ist das nicht so. Die haben kein extra Lötpad für PMW-. GND des PWM-Gebers (Arduino) und GND des Stromversorgers der KSG müssen immer verbunden sein. Sonst pwmt es nicht.

Das läuft jetzt alles immer noch ohne die RTC aber mit zwei Zeitschaltuhren, weil der Ardunio vor dem Licht angehen muss, um zeit zu haben, sein Programm zu starte, damit die Balken aus sind. Sonst gehen alle Lichter erst mal an, bis das Programm gestartet und die Lichter erst mal aus sind um dann aufgedimmt zu werden.
Genau dieses Problem haben andere auch. Ich verweise dann immer auf Coralux und deren KSQ-Platinen: http://coralux.net/?wpsc-product=ldd-4-driver-board. Betreibe selber mehrere von denen. Die zusammen mit DHL liefern schnell aus San Francisco. Zoll etc. erledigt DHL gegen Courtage automatisch.
Ein 10k Pulldown Widerstand zwischen PWM und GND der KSQ sorgt dafür, daß bei fehlendem PWM-Signal (Arduino startet noch) die Lichter aus bleiben. Dann brauchst Du die zweite Zeitschaltuhr nicht mehr.

Grüße, Markus
 

sabrikara

Member
Hi Markus,

omega":2246ifk2 schrieb:
nach meinem Verständnis ist PWM- eh mit GND der KSQ verbunden, also auch mit dem GND des Arduinos. Das zusätzliche Pad erspart einem das etwas mühseelige Anlöten zweier Litzen an ein Pad.

So wars eben nicht. Ich hatte erst GND des Arduinos auf das PWM- Pad gelötet. Funktionierte nicht. Irgendwo habe ich auch eine Zeichnung gesehen, dass PWM+ und PWM- in/auf der Platine zusammen gehen(?). Wahrscheinlich steckt hier die Erklärung dazu drin: "[...] ist kompatibel zu Controllern mit gemeinsamer Anode, wird parallel an die Spannungsversorgung des RGB-Controllers angeschlossen und erhält über die +/- Kanalausgänge das PWM-Signal, welches am BUCK an separaten Eingängen eingespeist wird"

omega":2246ifk2 schrieb:
Genau dieses Problem haben andere auch. Ich verweise dann immer auf Coralux und deren KSQ-Platinen: http://coralux.net/?wpsc-product=ldd-4-driver-board. Betreibe selber mehrere von denen.
Ein 10k Pulldown Widerstand zwischen PWM und GND der KSQ sorgt dafür, daß bei fehlendem PWM-Signal (Arduino startet noch) die Lichter aus bleiben. Dann brauchst Du die zweite Zeitschaltuhr nicht mehr.

Klingt interessant aber jetzt wo ich alles fertig verbaut habe, vielleicht dann doch erst fürs "nächste Mal". Am Arduino rumfuschen ist zu dem jetzigen Zeitpunkt einfacher als in der Lampe die KSQ zu tauschen und die Platine einzubauen.

So schlimm finde ich das mit den zwei Zeitschaltuhren ehrlich gesagt auch gar nicht.

Wie ich mir das mit der RTC vorstelle, weiß ich noch nicht.
Die Uhr dran und Arduino sowie Lampen laufen immer – so wären beide Zeitschaltuhren weg. Aber so richtig gut finde ich es nicht, wenn das alles auch Nachts laufen muss.

Lampen und Arduino an eine Zeitschaltuhr geht ja dann trotzdem nicht.

Lampe an Zeitschaltuhr, Arduino durchlaufen ist halt auch nicht das Wahre.

Moritz hatte was dazu geschrieben, habe ich jetzt aber nicht mehr im Kopf. Muss ich mir noch mal ansehen.
Wenn die RTC dran ist, könnte ich zumindest das "Delay" aus dem Programm-Code entfernen, damit Ihr zufrieden seid. ;)
 

steppy

Active Member
Hallo,
du kannst auch die komplette LED Stromversorgung über ein Relais ausschalten. So ist die Stromversorgung immer vom Netzt getrennt, es sei denn der Arduino schaltet sie ein. Die typischen "Arduino Relais" Module sind recht günstig und eignen sich ganz gut dafür. Ich habe es bei mir auch so gemacht.

Gruß
Stefan
 
Hallo Sabri,

das mit dem 10k sollte auch bei den PWM-Eingängen von Deinen KSQ funktionieren. Notfalls muss man den Wert noch etwas nach unten korrigieren (7.5k oder 6.8k), bis das Licht sicher aus ist.
Meine Anfrage beim Händler, was bei Deiner KSQ zwischen PWM- und Masse liegt, läuft noch. Man hat jetzt den Hersteller angefragt. Komisch, daß das noch kein Kunde wissen wollte...

Grüße
Uwe
 

Ähnliche Themen

Oben