Jebao DP-4 / AquaMedic EVO 4 / Dupla Marin P4 Smart

robbsen

Member
Hallo zusammen,

ich hab o.g. Dosierpumpen mal getestet. Alle zeigen bei mir gleiches Verhalten, was die Dosierung kleiner Mengen angeht. Angegeben ist im Datenblatt jeweils 1ml als minimales Volumen.

Jede der Dosierer und Pumpen pumpt immer 1ml zuviel, bei Soll 1ml kommen ca. 2 raus, bei Soll 2ml sind es 3ml usw.
Zeit gestoppt anhand Pumpengeräusch mit aufzeichnendem Dezibelmeter: 100ml -> 86s, 1ml -> 1,6s. Müssten aber 0,86s sein.

Wie gesagt, alle o.g. Dosierer getestet, alle gleiches Verhalten, basieren ja auch auf der selben Hardware und Software. Ist das auch schon jemandem aufgefallen? Bin ja geneigt, eine eigene Steuerung zu bauen, mit einem Atmega und zwei L298 sollte das doch möglich sein?!

Gruß Robert
 

nik

Moderator
Teammitglied
Moin Robert,

erst einmal Danke für den Bericht. Die erst Frage, die mir auftauchte, wie geht das mit der Kalibrierung zusammen?
Die nächste wäre, lässt sich das über die Kalibrierung beeinflussen.

Gruß Nik
 

robbsen

Member
nik":3rj71t1g schrieb:
Moin Robert,

erst einmal Danke für den Bericht. Die erst Frage, die mir auftauchte, wie geht das mit der Kalibrierung zusammen?
Die nächste wäre, lässt sich das über die Kalibrierung beeinflussen.

Gruß Nik

Hi Nik,

das passt gar nicht zusammen. Und lässt sich durch Kalibrierung auch nicht zufriedenstellend beeinflussen, da hier nur die Steigung und kein fester Offset kalibriert werden kann. Kalibriere ich bewusst falsch auf 50ml und nicht auf die geforderten 100ml, kommt bei Soll 1ml zwar etwa 1ml raus, aber bei Soll 100 dann eben nur etwa 50. Unbefriedigend.

Ich messe übrigens mit einer Feinwaage und einem Messbecher aus dem Chemiezubehör. Beides stimmt überein.

Hatte die Geräte auch mal aufgeschraubt, die Platinen sind äquivalent, nur etwas anders bestückt, je nachdem, ob das Gerät externe Steuerung oder interne hat, bzw. erweiterbar ist oder nicht.

Eine eigene Steuerung zu layouten traue ich mir durchaus zu.

Gruß Robert
 

Erwin

Well-Known Member
Hallo Robert,

Das Problem hat etwas mit dem mechanisch höheren Anlaufwiderstand der Pumpen zu tun. Diese ist nicht immer konstant.
Ich habe zwar keines von dir genannten Geräte, aber schon unterschiedliche Einzelschlauchpumpen mit Durchflussunterschieden. Steuere diese bei kleinstmengen nur noch zeitlich an und zähle die Tropfen. Wirds im Sekundenbereich zuviel veringere ich die Spannung.

MfG
Erwin
 

Anhänge

  • IMG_20200528_145323.jpg
    IMG_20200528_145323.jpg
    2,2 MB · Aufrufe: 264

robbsen

Member
Hallo Erwin,

führt dieser Anlaufwiderstand denn zu einer zu hohen Laufzeit bei geringen Mengen? Wie gesagt, bei 1ml laufen die Pumpen etwa doppelt so lang, wie sie eigentlich sollten und pumpen entsprechend doppelt so viel. Ich vermute eine vermurkste Berechnung im µC. Der treibt im Original ein Darlington-Array pro Motor zum Drehen.

Morgen kommen zwei L298N Brückentreiber hier an, da schließ ich mal eine Pumpe an und teste. Da kann man die Drehzahl dann über PWM steuern. Drehrichtung geht auch, könnte man zum Zurückpumpen nutzen. Elektrotechnik ist ja mein erstes Hobby :kaffee1:

Gruß Robert
 

Erwin

Well-Known Member
Hallo Robert,

achso, klar, nee. Habe ich falsch gelesen.

Kannst du rausfinden die kürzeste mögliche Schaltzeit?
Was mir bei meiner Antwort im Kopf rumging war, dass eine feste mindesteinschaltzeit vorgegeben ist, damit die Pumpe sicher anläuft.

MfG
Erwin
 

robbsen

Member
Erwin":1iunsj90 schrieb:
Hallo Robert,

achso, klar, nee. Habe ich falsch gelesen.

Kannst du rausfinden die kürzeste mögliche Schaltzeit?
Was mir bei meiner Antwort im Kopf rumging war, dass eine feste mindesteinschaltzeit vorgegeben ist, damit die Pumpe sicher anläuft.

MfG
Erwin

Hi Erwin,

das kann ja durchaus sein, dass da eine Mindestdauer addiert wird. Werde wie gesagt morgen mit den Motortreibern und einem Arduino experimentieren. :thumbs:

Gruß Robert
 

robbsen

Member
Hallo,

wie erwartet lässt sich die Pumpe mit dem L289N sauber steuern. Für 1ml setzt man genau 1/100 der Zeit von 100ml an und bekommt perfekte Ergebnisse, anders als bei den Original-Steuerungen. Von 10x 1ml Soll bekomme ich 8x 1,0ml und 2x 0,9ml. Passt also. Werde also eine AtMega/L289 - basierte Steuerung in Angriff nehmen.

Gruß Robert



[BBvideo 425,350:266bozmu]https://youtu.be/Svv3Vkcv-28[/BBvideo]
 

Anhänge

  • DAD0C99F-80BC-43A9-ACFA-E900B1265F1D.jpeg
    DAD0C99F-80BC-43A9-ACFA-E900B1265F1D.jpeg
    1,7 MB · Aufrufe: 175
Hi Robert,

möglich wäre auch, dass die geräteinterne Stromversorgung zu schwach ausgelegt ist und im Anlaufmoment einbricht. Hast du Lust, das mal zu messen?

Grüße
Uwe
 

Ähnliche Themen

Oben