Post Reply
158 posts • Page 2 of 11
Postby sabrikara » 27 Jun 2015 20:56
Hi zusammen,

heute sind die BUZ11 angekommen und hab diese wie Otto zu Anfang gesagt hatte angeschlossen. Hat super funktioniert. Die Freude währte allerdings nicht all zu lang. Nach dem dritten Test Skript, Sketch, Programm oder wie man sagt, verabschiedete sich der Arduino.
Zumindest teilweise. Ich kriege kein neues Programm mehr drauf. Der, der drauf ist ist natürlich noch "nix".
Fehlermeldung: avrdude: stk500_recv(): programmer is not responding. Schließe ich den Arduino an den Computer wird der so heiß, dass man den kaum noch anfassen kann. Hab hin und her probiert und dann einfach neu bestellt :roll: Ein neues Netzteil mir richtigen Spezifikationen ist auch unterwegs. Dann muss ich mich halt noch mal gedulden. Nochmals Danke.
Liebe Grüße
Sabri
User avatar
sabrikara
Posts: 509
Joined: 25 Feb 2013 20:05
Location: Essen
Feedback: 1 (100%)
Postby omega » 28 Jun 2015 00:02
Hallo Sabri,

schade. Bist Du der Ursache auf den Grund gegangen? Ansonsten wird Dir dasselbe wieder passieren.
Zeig doch mal ein aussagekräftiges Bild des Aufbaus, wenn Du die Ursache nicht kennst.

Grüße, Markus
User avatar
omega
Posts: 2781
Joined: 12 Sep 2012 20:53
Location: München
Feedback: 9 (100%)
Postby sabrikara » 28 Jun 2015 08:41
Hi Markus,

ich wüsste nicht wie. Dachte eventuell hab ich eine endlos schleife reingeschrieben aber auch der Trick mit dem Resetknopf vor Upload eines neuen Codes funktioniert nicht. Nur wenn ich den Arduino anschließe, wird der schon heiß.
Anbei das Bild.
Pin 10 hab ich benutzt. Rot vom PWM Arduino zum Drain am BUZ 11. Gate an Meanwell Dim+. Meanwell Dim - an Source vom Buz11 und von da zum Ground von Pin 10.

Attachments

Liebe Grüße
Sabri
User avatar
sabrikara
Posts: 509
Joined: 25 Feb 2013 20:05
Location: Essen
Feedback: 1 (100%)
Postby OttoFaerber » 28 Jun 2015 11:04
Pwm arduino muss an gate von buzz
Grüße aus Bayern

der Otto
User avatar
OttoFaerber
Posts: 300
Joined: 10 Feb 2012 17:37
Feedback: 3 (100%)
Postby sabrikara » 28 Jun 2015 12:06
Huhu,

hmmm. Anfangs hats nicht funktioniert, am Programm hats aber nicht gelegen und hab dann umgesteckt. Dann hat es geklappt. Dann gings scheinbar falschrum. Hab das dann durch den Arduino gejagt. Ein zwei mal hat er es dann wohl ausgehalten und hat sich dann aber verabschiedet?

Otto, deine Zeichnung ist bei Drain und Source andersrum, als deine Aussage. Aber das wird egal sein wie rum das "kurzgeschlossen" wird.

Naja. Schauen wir mal wenn Ersatz da ist :)
Liebe Grüße
Sabri
User avatar
sabrikara
Posts: 509
Joined: 25 Feb 2013 20:05
Location: Essen
Feedback: 1 (100%)
Postby OttoFaerber » 28 Jun 2015 12:13
Ups fehler in der Zeichnung, gehört andersrum.
Ist nicht egal.
Und Arduino pwm an gate ist wichtig
Grüße aus Bayern

der Otto
User avatar
OttoFaerber
Posts: 300
Joined: 10 Feb 2012 17:37
Feedback: 3 (100%)
Postby OttoFaerber » 28 Jun 2015 12:19
Hab mir dei bild angeschaut, wenn ich das richtig sehe schliesst du deinen arduino ausgang kurz
Grüße aus Bayern

der Otto
User avatar
OttoFaerber
Posts: 300
Joined: 10 Feb 2012 17:37
Feedback: 3 (100%)
Postby OttoFaerber » 28 Jun 2015 12:27
Hier mal die pinbelegung

Attachments

Grüße aus Bayern

der Otto
User avatar
OttoFaerber
Posts: 300
Joined: 10 Feb 2012 17:37
Feedback: 3 (100%)
Postby sabrikara » 28 Jun 2015 13:04
Huhu,

Danke Otto. Habs noch mal richtig angeschlossen aber wie zu erwarten läuft nix mehr.
Muss warten bis Ersatz da ist.

Also so anschliesen:
"einfach Gate an PWM Ausgang
Sorce an Masse Rasp und masse Meanwell PWM
Drain an + Meanwell.
Ohne weitere Beschaltung."
Liebe Grüße
Sabri
User avatar
sabrikara
Posts: 509
Joined: 25 Feb 2013 20:05
Location: Essen
Feedback: 1 (100%)
Postby omega » 28 Jun 2015 22:33
Hallo Sabri,

sabrikara wrote:Also so anschliesen:
"einfach Gate an PWM Ausgang
Sorce an Masse Rasp und masse Meanwell PWM
Drain an + Meanwell.
Ohne weitere Beschaltung."

ja.
Mit anderen Worten:
PWM vom Nano an Gate.
GND vom Nano und DIM- vom Meanwell an Source.
DIM+ vom Meanwell an Drain.

Mit DIM+ = 10V am Gate hast Du den BUZ11 zwischen Drain und Source runter auf 30mΩ gedrückt und PWM mit GND des Nanos kurzgeschlossen und dadurch den Nano gegrillt.

Beim BUZ11 bin ich mir bei meinem laienhaften Verständinis des Datenblatts nicht sicher, ob der bei den 3.3V des Nanos am Gate überhaupt voll durchschaltet. Bei VGS = VTH fängt ein Mosfet doch erst an durchzuschalten. Beim BUZ11 liegt VTH bei 2.1-4V, und rDS ist bei VGS = 10V angegeben, weit weg von 3.3V.

EDIT:
Wenn ich das richtig sehe, muß ein Mosfet nur für maximalen Strom voll durchschalten. Hier geht es aber um die 10V-Spannung vom LCM-40, die zu einem PWM-Signal zerhackt werden soll. Wieviel Strom dabei fließt, ist wohl eher zweitrangig.

Grüße, Markus
User avatar
omega
Posts: 2781
Joined: 12 Sep 2012 20:53
Location: München
Feedback: 9 (100%)
Postby Wuestenrose » 29 Jun 2015 09:04
Morgen…

Drum habe ich weiter oben den 2N7000 vorgeschlagen. Der schaltet bei 3 Volt VGS bereits sicher durch. Zudem besitzt er nur den Bruchteil der Gate-Source-Kapazität des BUZ11-Oschis, d. h. der Arduino muß beim Umladen wesentlich weniger Strom liefern, was auch die Schaltzeit des Transistors beeinfluß. Spielt bei den paar Hundert Hertz einer PWM-Steuerung keine besondere Rolle, soll aber als Nebeneffekt nicht unerwähnt bleiben.

Grüße
Robert
生命太短暂无法在床上死去。
User avatar
Wuestenrose
Posts: 6549
Joined: 26 Jun 2009 10:46
Location: Im Herzen der Renaissance- und Fuggerstadt Augsburg
Feedback: 4 (100%)
Postby omega » 29 Jun 2015 22:16
Hi,

ein Fehler: der Nano läuft gar nicht bei 3.3V sondern 5V, also wohl nicht ganz so kritisch.
Mir ist noch der Begriff "Logic Level Mosfet" über den Weg gelaufen.
Wenn der BUZ11 nicht genug durchschaltet, wird's ein solcher. Eine Übersicht gibt's dort: http://www.mikrocontroller.net/articles/MOSFET-%C3%9Cbersicht

Grüße, Markus
User avatar
omega
Posts: 2781
Joined: 12 Sep 2012 20:53
Location: München
Feedback: 9 (100%)
Postby sabrikara » 30 Jun 2015 11:14
Hi zusammen,

nur kurz:

"Wer einen BUZ11 (V_{{GS}}(th) 4V max.) mit 5V ansteuert riskiert ein Abfackeln des MOSFETs, denn je nach Toleranz kann er bereit ganz gut aufgesteuert sein oder auch nicht."
Quelle - unter der Tabelle "Erklärung der wichtigsten Datenblattwerte"
Liebe Grüße
Sabri
User avatar
sabrikara
Posts: 509
Joined: 25 Feb 2013 20:05
Location: Essen
Feedback: 1 (100%)
Postby Wuestenrose » 30 Jun 2015 11:30
Mahlzeit..,

Bei den paar Mikroampere, die die Dimmschnittstelle eines LCM-40 liefern kann, fackelt garantiert nix ab. Wenn der BUZ nicht ganz durchschaltet, dimmt hält das LCM nicht richtig.

Grüße
Robert
生命太短暂无法在床上死去。
User avatar
Wuestenrose
Posts: 6549
Joined: 26 Jun 2009 10:46
Location: Im Herzen der Renaissance- und Fuggerstadt Augsburg
Feedback: 4 (100%)
Postby sabrikara » 30 Jun 2015 12:04
Huhu,

alles klar. Ich mein hier und da wird das Ding ja im Netz benutzt, also ahnte ich schon dass die Aussage eventuell nicht auf "meine" Konstellation zu trifft. Dann werde ich mal weiter versuchen der Leistungselektronik auf den Grund zu gehen. ;)
Danke.
Liebe Grüße
Sabri
User avatar
sabrikara
Posts: 509
Joined: 25 Feb 2013 20:05
Location: Essen
Feedback: 1 (100%)
158 posts • Page 2 of 11
Related topics Replies Views Last post
Arduino-Aquariumsteuerung?
by kos » 21 Jun 2012 18:32
13 10028 by Ortin View the latest post
29 Jun 2012 20:26
MeanWell Netzteil
Attachment(s) by Diskus79 » 02 Aug 2015 13:31
6 679 by omega View the latest post
03 Aug 2015 23:24
Wie sind eure Erfahrungen mit 4er Relay für den Arduino
by Ingo79 » 31 Oct 2014 13:50
1 513 by Wuestenrose View the latest post
31 Oct 2014 15:25
Aquaduino - Arduino powered Aquarium Controller
by NatroN » 05 Jan 2015 15:47
12 6130 by Anton. View the latest post
04 Sep 2019 18:30
Aqua Medic Qube Control Steuerung -> 0-10V an Meanwell KSQ?
Attachment(s) by simonsambuca » 10 Mar 2020 16:56
7 258 by Mandocello View the latest post
17 Mar 2020 16:29

Who is online

Users browsing this forum: No registered users and 9 guests