Post Reply
45 posts • Page 3 of 3
Postby Lea » 30 Aug 2016 09:37
Guten Tag Robert,

ich habe versucht die Variante mit Widerstandsteiler nachzubauen. Dabei habe ich Zenerdioden Z-Dioden in axialer - und SMD-Bauform mit 1,3 Watt verbaut. Muss hierbei erwähnen dass ich kaum Ahnung habe von der Materie und bitte um Rücksicht :besserwiss: .
Den TC 420 habe ich so ein gestellt:

Uhrzeit Lichtstärke
1. 07:00 100%
2. 11:00 0%
3. 16:00 0%
4. 20:00 100%

Folgendes ist mir aufgefallen.

1. Das Licht wird gedimmt mit umgekehrten Einstellungen im TC420
2. Das Licht wird nie auf 0% runter gedimmt sondern leuchtet noch ganz schwach.
3. Zirka bei 0:00 Uhr schaltet es auf zirka 100%

Ich wollte nur das Beste für meine Fische und nun der :shock:

LG

Lea

Attachments

Lea
Posts: 4
Joined: 25 Aug 2016 14:29
Feedback: 0 (0%)
Postby eheimliger » 30 Aug 2016 14:24
Hallo Lea,
zu der Schaltung kann ich nichts sagen, aber wenn Du schreibst das es um Mitternacht 100% ist, ist das dann in wirklichkeit nur noch leicht am glimmen oder wirklich bei 100%, verstehe das nicht ganz.
Zum leichten glimmen könntest Du versuchen vor dem festgelegtem Zeitpunkt über Fade auf 1% zu gehen, und dann 1 Minute später über Jump auf 0%. Wenn es verkehrt herum laufen soll dann also Fade bis 99 und dann den regler auf Jump und 100%.
Also in deinem Beispiel wäre das.
1. 07:00 100%
2. 11:00 0%
3. 16:00 0%
4. 19:59 99%
5. 20:00 100%
vielleicht funktioniert das ja.
Gruß, Frank
eheimliger
Posts: 917
Joined: 26 Nov 2015 19:35
Location: Bonn
Feedback: 4 (100%)
Postby Wuestenrose » 30 Aug 2016 14:51
Hallo…

Lea wrote:1. Das Licht wird gedimmt mit umgekehrten Einstellungen im TC420

Wie Uwe in diesem Beitrag schon beschreibt, reagiert die Leuchte umgekehrt zu den Einstellungen des TC420. Ich weiß nicht, ob man den TC420 so programmieren kann, daß er die Ausgänge invertiert (ich habe keinen, bei dem ich es ausprobieren könnte). Wenn nicht, muß man ihn halt umgekehrt programmieren.


Grüße
Robert
生命太短暂无法在床上死去。
User avatar
Wuestenrose
Posts: 6445
Joined: 26 Jun 2009 10:46
Location: Im Herzen der Renaissance- und Fuggerstadt Augsburg
Feedback: 4 (100%)
Postby Lea » 30 Aug 2016 15:10
Hallo eheimliger,

vielen Dank für deine schnelle Antwort.
Also rein von Betrachen der Lampe sieht es so aus (dabei sei zu sagen dass ich die Lampe zirka um 16 Uhr in Bertieb genommen habe):

1.Lampe leuchtet und mit verstreichender Zeit nimmt ihre Lichtstärke ab (bis jetzt alles super)
2.Sie schaltet jedoch nie komplett ab - so als ob sie mit 5-10% Lichtstärke weiter läuft.
3.Plötzlich bei zirka 0:00 +-30 min hat sie wieder nahezu 100% Lichtstärke und behält diese (zirka 30 min getestet)

Das Alles bei

TC 420 habe ich so ein gestellt:

Uhrzeit Lichtstärke
1. 07:00 100%
2. 11:00 0%
3. 16:00 0%
4. 20:00 100%



LG

Lea

P.S. Ich vermute als Laie dass vllt mit der Diode was nicht stimmt.
Lea
Posts: 4
Joined: 25 Aug 2016 14:29
Feedback: 0 (0%)
Postby Lea » 30 Aug 2016 15:13
Hallo Robert,

danke für deine Antwort. Ich habe diese Tatsachen nur hier niedergeschrieben damit man vielleicht besser den Fehler nachvollziehen kann. Im Grunde will ich nur den Fehler beheben, der dazu führt, dass die Lampe einfach um Mitternacht wieder 100% Lichtkraft hat.

LG

Lea
Lea
Posts: 4
Joined: 25 Aug 2016 14:29
Feedback: 0 (0%)
Postby eheimliger » 30 Aug 2016 15:25
Bin jetzt auch kein Diodenexperte, vermute aber da sie sich nicht verändert im laufe des Tages.

Mach doch mal ein "Clear all" und danach den Resetknopf direkt am TC, danach neu bespielen.
Zur Not wenn es immer noch zu der nächtlichen Einschaltung kommt folgendes Programm.
1. 0:01 100% Jump
2. 07:00 100% Fade
3. 11:00 0% Fade
4. 16:00 0% Fade
5. 19:59 99% Fade
6. 20:00 100% Jump
7. 0:00 100% Jump
Gruß, Frank
eheimliger
Posts: 917
Joined: 26 Nov 2015 19:35
Location: Bonn
Feedback: 4 (100%)
Postby Wuestenrose » 30 Aug 2016 18:03
Servus...

@Uwe
Mandocello wrote:Wie üblich lässt sich die KSQ analog nicht so weit herunterdimmen, wie mit PWM.

Verstehe ich nicht recht. Was ist denn der Unterschied zwischen einem 0-%-PWM-Signal und analogen 0 Volt?

@Lea
Lea wrote:Im Grunde will ich nur den Fehler beheben, der dazu führt, dass die Lampe einfach um Mitternacht wieder 100% Lichtkraft hat.

Dabei muß es sich um einen Programmierfehler oder einen Fehler des TC420 handeln. Uwes Schaltung ist daran definitiv unschuldig.

Grüße
Robert
生命太短暂无法在床上死去。
User avatar
Wuestenrose
Posts: 6445
Joined: 26 Jun 2009 10:46
Location: Im Herzen der Renaissance- und Fuggerstadt Augsburg
Feedback: 4 (100%)
Postby Mandocello » 30 Aug 2016 21:44
Guten Abend,

@Robert,

der Unterschied liegt im Verhalten des Dimmeingangs. Für ein analoges Dimmsignal haben zumindest alle Controller-ICs, die ich kenne, eine etwas erhöhte untere Schaltschwelle. Sagen wir mal bei 0.3V schaltet der Dimmeingang ein und bei 1.2V hat er 100% erreicht. Das macht man, damit Störungen, die man sich bei einem Schaltregler leicht einfängt, nicht die LEDs um den Nullpunkt herum zum Flackern bringen. Nachteil ist, dass die Dimmung in unserem Beispiel dann erst bei 25% einschaltet. Bei Dimmung mit PWM wird immer zwischen 0 und 100% geschaltet und dieser Effekt kommt nicht zur Wirkung.

@ Lea

Wenn Du nur die Leuchte alleine an 24V anschließt und den PWM-Eingang mit Masse verbindest ist aber richtig aus? Vorsicht, nicht +24V an PWM legen, dann ist sie im Himmel!

Grüße
Uwe
Mandocello
Posts: 354
Joined: 05 Jun 2015 10:00
Feedback: 2 (100%)
Postby Wuestenrose » 31 Aug 2016 05:40
Morgen…

Mandocello wrote:der Unterschied liegt im Verhalten des Dimmeingangs.

Nochmal: Was ist der Unterschied zwischen einem 0-%-PWM-Signal und analogen 0 Volt?

Grüße
Robert
生命太短暂无法在床上死去。
User avatar
Wuestenrose
Posts: 6445
Joined: 26 Jun 2009 10:46
Location: Im Herzen der Renaissance- und Fuggerstadt Augsburg
Feedback: 4 (100%)
Postby Mandocello » 31 Aug 2016 10:25
Hallo miteinander,

@ Lea
Wenn ich Deine Verdrahtung mal nachvollziehe, ist am Leuchtenkabel
gelb - PWM, rot - Masse/GND und schwarz VCC/+24V.
Ist das korrekt?

@ Robert
Analoge 0V sind 0V. Ein PWM-Signal von 0% kann jeden Spannungswert unterhalb der Erkennungsschwelle des nachgelagerten Gerätes aufweisen.

Grüße
Uwe
Mandocello
Posts: 354
Joined: 05 Jun 2015 10:00
Feedback: 2 (100%)
Postby Wuestenrose » 31 Aug 2016 10:44
Gut,

nachdem du dich nach wie vor um eine konkrete Antwort herumdrückst:

Worin konkret besteht bei der Dennerle Scapers LED der Unterschied zwischen einem 0-%-PWM-Signal und analogen 0 Volt? In diesem Beitrag schlägst du doch Lea höchstselbst vor, zur Kontrolle mal an den PWM-Eingang 0 Volt anzulegen (= mit Masse zu verbinden)?


Grüße
Robert
生命太短暂无法在床上死去。
User avatar
Wuestenrose
Posts: 6445
Joined: 26 Jun 2009 10:46
Location: Im Herzen der Renaissance- und Fuggerstadt Augsburg
Feedback: 4 (100%)
Postby Mandocello » 31 Aug 2016 13:41
Hallo Robert,

worauf willst Du hinaus?

Zwischen analogen 0V und 0% PWM gibt es keinen Unterschied. Die auswertende Hardware ist ja auch die selbe. Der Unterschied ergibt sich aus der Betriebsweise.

Der Kurzschluss nach Masse ist für mich ein Testsignal, dem ich gut vertrauen kann. Ob aus dem TC420 0% PWM herauskommt, kann ich ohne Hilfsmittel schlecht bewerten.

Grüße
Uwe
Mandocello
Posts: 354
Joined: 05 Jun 2015 10:00
Feedback: 2 (100%)
Postby Wuestenrose » 31 Aug 2016 13:59
Mahlzeit…

Mandocello wrote:worauf willst Du hinaus?

Ganz einfach: Weiter oben schriebst Du, daß sich die KSQ analog "wie üblich" nicht so weit herunterdimmen ließe wie mit PWM. Das brachte mich zu der Frage und zum nachfolgenden Insistieren, worin denn der Unterschied zwischen einem 0-%-PWM-Signal und analogen 0 Volt bestünde. Daß sich die KSQ mit beiden Signalen bis Null herab dimmen läßt, hast Du ja selbst bestätigt.

Grüße
Robert
生命太短暂无法在床上死去。
User avatar
Wuestenrose
Posts: 6445
Joined: 26 Jun 2009 10:46
Location: Im Herzen der Renaissance- und Fuggerstadt Augsburg
Feedback: 4 (100%)
Postby Mandocello » 31 Aug 2016 16:08
Hallo Robert,

Du kannst mit beiden Methoden auf den Zustand Null dimmen, also abschalten. Aber Du kannst Dich analog nicht kontinuierlich der Null nähern. Es wird nur mit PWM gelingen, z.B. 5% LED-Strom einzustellen. Hierfür bräuchte man einen analogen Pegel von 3V x 5% / 100% = 0.15V Der liegt unterhalb der Ein-/Ausschaltschwelle, bei meiner Leuchte mit 0.33V / 0.27V vermessen.
Es bleibt duster.

Grüße
Uwe

edit: Grafik dazu s. unten

Attachments

Mandocello
Posts: 354
Joined: 05 Jun 2015 10:00
Feedback: 2 (100%)
Postby Mandocello » 01 Sep 2016 12:49
Hi Lea,

lass Dich mal nicht durch unser Geplänkel entmutigen. Gibt es schon Fortschritte? Es sind offenbar drei Punkte: der fehlerhafte Schaltvorgang, die korrekte Einstellung des invertierten Programms und das nicht vollständige Ausdimmen. Ich würde erstmal die Programmierung soweit geradeziehen, dass sie richtig läuft. Dann knöpfen wir uns die Resthelligkeit vor.

Der TC420 braucht doch offenbar an jedem Programmierpunkt eine Information, auf welche neue Helligkeit er gehen soll. Die vorher eingestellte wird bis zu diesem Punkt beibehalten. Dein Programm mit Mittagspause müsste ohne Invertierung m.E. so aussehen:

07:00 100%
11:00 0%
16:00 100%
20:00 0%

und invertiert:
07:00 0%
11:00 100%
16:00 0%
20:00 100%

Dein Programm (nicht invertiert) von weiter oben liest sich hingegen wie:
1. 07:00 100% schalte an
2. 11:00 0% schalte aus
3. 16:00 0% bleibe aus
4. 20:00 100% schalte an, über Mitternacht hinaus

Was sagen die TC420-User dazu?

Auf der Website von Darren mit Erklärungen zum Setup des TC420 findet sich ein Hinweis auf einen Bug:
"NOTE: I have discovered a bug with the controller that seems to effect modes that are transitioning over midnight, in that they don't fade smoothly over midnight."

Der arbeitet bei Tagumschaltung offenbar nicht ganz sauber. Das sollte bei Dir keine Auswirkung haben, weil es keine Dimmaktion über Mitternacht gibt. Es gäbe aber die Möglichkeit, dass die Zeit nicht korrekt synchronisiert ist, mach das mal bitte und kontrolliere, ob er auch genau an den programmierten Zeiten schaltet.

Grüße
Uwe
Mandocello
Posts: 354
Joined: 05 Jun 2015 10:00
Feedback: 2 (100%)
45 posts • Page 3 of 3
Related topics Replies Views Last post
Dennerle Nano Co2 Adapter auf 500g Flasche?
by sajo » 10 Dec 2011 21:35
2 1246 by kiko View the latest post
10 Dec 2011 23:09
Suche Adapter für Dennerle Profi 500 Anlage
by crowdsurfer » 14 Feb 2013 16:43
1 926 by crowdsurfer View the latest post
14 Feb 2013 17:31
Dennerle Scapers Filter und Garnelen?
by garnele1234 » 24 Jan 2014 00:49
4 1003 by matze87 View the latest post
05 Feb 2014 10:41
Dennerle Scapers Tank 35l. Technik
by darkwing-duck » 30 Apr 2018 11:03
2 585 by darkwing-duck View the latest post
30 Apr 2018 13:03
Filterbestückung Dennerle Scapers Flow
by Somnium » 31 Oct 2018 23:25
3 420 by unbekannt1984 View the latest post
04 Nov 2018 20:14

Who is online

Users browsing this forum: No registered users and 2 guests